Command:

setup

Mode:

Router#


Syntax:

setup


Syntax Description:

This command has no arguments or keywords.


Command Description:
To enter the setup command facility, use the setup privileged EXEC command. You can use the setup command facility to create a basic configuration to get a router up and running, but for advanced features and fine tuning of router processes, use the command line. You might want to use setup to add a protocol suite, to make major addressing scheme changes, or to configure a newly installed interface. While you can use the command parser to make these major changes, the setup command facility provides you with a high-level view of the configuration and guides you through the configuration  change process.

Additionally, if you are not familiar with Cisco products and the command parser, the setup command  facility is a particularly valuable tool because it asks you the questions required to make configuration changes.


Note If you use setup to modify a configuration because you have added or modified the hardware, be sure to verify the physical connections using the show version command. Also, verify the logical port assignments using the show running-config command to ensure that you configure the correct port. Refer to your platform's hardware publications for details on physical and logical port assignments. 

Whenever you use the setup command facility, be sure that you have the following information:

When you enter the setup command facility after first-time startup, an interactive dialog called the System Configuration Dialog appears on the system console screen. The System Configuration Dialog guides you through the configuration process. It prompts you first for global parameters and then for interface parameters. The values shown in brackets next to each prompt are the default values last set using either the setup command facility or the configure command.


Note The prompts and the order in which they appear on the screen vary depending on the platform and the interfaces installed in the device.

You must run through the entire System Configuration Dialog until you come to the item that you intend to change. To accept default settings for items that you do not want to change, press the Enter key.

To return to the privileged EXEC prompt without making changes and without running through the entire System Configuration Dialog, press Ctrl-C.

The facility also provides help text for each prompt. To access help text, press the question mark (?) key at a prompt.

When you complete your changes, the setup command facility shows you the configuration command script that was created during the setup session. The router displays the following options: 

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit. Enter your selection [2]:

The Cisco IOS software automatically puts you in the streamlined setup command facility when your router is accidentally or intentionally rebooted (or you are attempting to load a system image from a network server) after any of the following circumstances:

The streamlined setup command facility permits your router to load a system image from a network server when there are problems with the startup configuration.

The streamlined setup command facility differs from the standard setup command facility because the streamlined facility does not ask you to configure global router parameters. You are prompted only to configure interface parameters, which permit your router to boot.

The streamlined setup command facility is available only if your router is running from ROM monitor and has RXBOOT ROMs installed. The following routers can have this type of ROM installed:

 


Examples:

The following example shows how to use the setup command facility to configure interface serial  0/0 and to add ARAP and IP/IPX PPP support on the asynchronous interfaces.

Router#setup
         --- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Continue with configuration dialog? [yes]:
First, would you like to see the current interface summary? [yes]:
Interface          IP-Address      OK?  Method    Status                 Protocol
FastEthernet0/0         172.16.72.2     YES  manual    up                     up
Serial0            unassigned      YES  not set   administratively down  down
Serial1            172.16.72.2     YES  not set   up                     up
Configuring global parameters:
  Enter host name [Router]:
The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
  Enter enable secret [<Use current secret>]:
The enable password is used when there is no enable secret
and when using older software and some boot images.
  Enter enable password [ww]:
  Enter virtual terminal password [ww]:
  Configure SNMP Network Management? [yes]:
    Community string [public]:
  Configure DECnet? [no]:
  Configure AppleTalk? [yes]:
    Multizone networks? [no]: yes
  Configure IPX? [yes]:
  Configure IP? [yes]:
    Configure IGRP routing? [yes]:
      Your IGRP autonomous system number [15]:
  Configure Async lines? [yes]:
    Async line speed [9600]: 57600
    Configure for HW flow control? [yes]:
    Configure for modems? [yes/no]: yes
      Configure for default chat script? [yes]: no
    Configure for Dial-in IP SLIP/PPP access? [no]: yes
      Configure for Dynamic IP addresses? [yes]: no
      Configure Default IP addresses? [no]: yes
      Configure for TCP Header Compression? [yes]: no
      Configure for routing updates on async links? [no]:
    Configure for Async IPX? [yes]:
    Configure for Appletalk Remote Access? [yes]:
      AppleTalk Network for ARAP clients [1]: 20
      Zone name for ARAP clients [ARA Dialins]:
Configuring interface parameters:
Configuring interface FastEthernet0/0:
  Is this interface in use? [yes]:
  Configure IP on this interface? [yes]:
    IP address for this interface [172.16.72.2]:
    Number of bits in subnet field [8]:
    Class B network is 172.16.0.0, 8 subnet bits; mask is /24
  Configure AppleTalk on this interface? [yes]:
    Extended AppleTalk network? [yes]:
    AppleTalk starting cable range [1]:
    AppleTalk ending cable range [1]:
    AppleTalk zone name [Sales]:
    AppleTalk additional zone name:
  Configure IPX on this interface? [yes]:
    IPX network number [1]:
Configuring interface Serial0:
  Is this interface in use? [no]: yes
  Configure IP on this interface? [no]: yes
  Configure IP unnumbered on this interface? [no]: yes
    Assign to which interface [FastEthernet0/0]:
  Configure AppleTalk on this interface? [no]: yes
    Extended AppleTalk network? [yes]:
    AppleTalk starting cable range [2]: 3
    AppleTalk ending cable range [3]: 3
    AppleTalk zone name [myzone]: ZZ Serial
    AppleTalk additional zone name:
  Configure IPX on this interface? [no]: yes
    IPX network number [2]: 3
Configuring interface Serial1:
  Is this interface in use? [yes]:
  Configure IP on this interface? [yes]:
  Configure IP unnumbered on this interface? [yes]:
    Assign to which interface [FastEthernet0/0]:
  Configure AppleTalk on this interface? [yes]:
    Extended AppleTalk network? [yes]:
    AppleTalk starting cable range [2]:
    AppleTalk ending cable range [2]:
    AppleTalk zone name [ZZ Serial]:
    AppleTalk additional zone name:
  Configure IPX on this interface? [yes]:
    IPX network number [2]:
Configuring interface Async1:
    IPX network number [4]:
    Default client IP address for this interface [none]: 172.16.72.4
Configuring interface Async2:
    IPX network number [5]:
    Default client IP address for this interface [172.16.72.5]:
Configuring interface Async3:
    IPX network number [6]:
    Default client IP address for this interface [172.16.72.6]:
Configuring interface Async4:
    IPX network number [7]:
    Default client IP address for this interface [172.16.72.7]:
Configuring interface Async5:
    IPX network number [8]:
    Default client IP address for this interface [172.16.72.8]:
Configuring interface Async6:
    IPX network number [9]:
    Default client IP address for this interface [172.16.72.9]:
Configuring interface Async7:
    IPX network number [A]:
    Default client IP address for this interface [172.16.72.10]:
Configuring interface Async8:
    IPX network number [B]:
    Default client IP address for this interface [172.16.72.11]:
Configuring interface Async9:
    IPX network number [C]:
    Default client IP address for this interface [172.16.72.12]:
Configuring interface Async10:
    IPX network number [D]:
    Default client IP address for this interface [172.16.72.13]:
Configuring interface Async11:
    IPX network number [E]:
    Default client IP address for this interface [172.16.72.14]:
Configuring interface Async12:
    IPX network number [F]:
    Default client IP address for this interface [172.16.72.15]:
Configuring interface Async13:
    IPX network number [10]:
    Default client IP address for this interface [172.16.72.16]:
Configuring interface Async14:
    IPX network number [11]:
    Default client IP address for this interface [172.16.72.17]:
Configuring interface Async15:
    IPX network number [12]:
    Default client IP address for this interface [172.16.72.18]:
Configuring interface Async16:
    IPX network number [13]:
    Default client IP address for this interface [172.16.72.19]:
The following configuration command script was created:
hostname Router
enable secret 5 $1$krIg$emfYm/1OwHVspDuS8Gy0K1
enable password ww
line vty 0 4
password ww
snmp-server community public
!
no decnet routing
appletalk routing
ipx routing
ip routing
!
line 1 16
speed 57600
flowcontrol hardware
modem inout
!
arap network 20 ARA Dialins
line 1 16
arap enable
autoselect
!
! Turn off IPX to prevent network conflicts.
interface FastEthernet0/0
no ipx network
interface Serial0
no ipx network
interface Serial1
no ipx network
!
interface FastEthernet0/0
ip address 172.16.72.2 255.255.255.0
appletalk cable-range 1-1 1.204
appletalk zone Sales
ipx network 1
no mop enabled
!
interface Serial0
no shutdown
no ip address
ip unnumbered FastEthernet0/0
appletalk cable-range 3-3
appletalk zone ZZ Serial
ipx network 3
no mop enabled
!
interface Serial1
no ip address
ip unnumbered FastEthernet0/0
appletalk cable-range 2-2 2.2
appletalk zone ZZ Serial
ipx network 2
no mop enabled
!
Interface Async1
ipx network 4
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.4
async mode interactive
!
Interface Async2
ipx network 5
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.5
async mode interactive
!
Interface Async3
ipx network 6
ip unnumbered Ethernet0/0
peer default ip address 172.16.72.6
async mode interactive
!
Interface Async4
ipx network 7
ip unnumbered Ethernet0/0
peer default ip address 172.16.72.7
async mode interactive
async dynamic address
!
Interface Async5
ipx network 8
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.8
async mode interactive
!
Interface Async6
ipx network 9
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.9
async mode interactive
!
Interface Async7
ipx network A
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.10
async mode interactive
!
Interface Async8
ipx network B
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.11
async mode interactive
!
Interface Async9
ipx network C
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.12
async mode interactive
!
Interface Async10
ipx network D
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.13
async mode interactive
!
Interface Async11
ipx network E
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.14
async mode interactive
!
Interface Async12
ipx network F
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.15
async mode interactive
!
Interface Async13
ipx network 10
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.16
async mode interactive
!
Interface Async14
ipx network 11
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.17
async mode interactive
!
Interface Async15
ipx network 12
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.18
async mode interactive
!
Interface Async16
ipx network 13
ip unnumbered FastEthernet0/0
peer default ip address 172.16.72.19
async mode interactive
!
router igrp 15
network 172.16.0.0
!
end
Use this configuration? [yes/no]: yes

Building configuration...
Use the enabled mode 'configure' command to modify this configuration.

Router#

The following example shows a router entering the streamlined setup command facility:


---
System Configuration Dialog ---
Default settings are in square brackets
  '[]'.
Configuring interface IP parameters for netbooting:  



Note The message "Configuring interface IP parameters for netbooting" only appears if you are booting over a network server and your configuration has insufficient IP information.

The streamlined setup command facility continues by prompting you for interface parameters for each installed interface. The facility asks if an interface is in use. If so, the facility then prompts you to provide an IP address and subnet mask bits for the interface. Enter the subnet mask bits as a decimal value, such as 5. Continuing with the streamlined setup command facility example, the following output shows the portion of the facility that prompts for interface parameters. In the example, the facility is prompting for FastEthernet 0/0 interface parameters and Serial 0 interface parameters:

Configuring interface FastEthernet0/0:
  Is this interface in use? [yes]:
  Configure IP on this interface? [yes]:
    IP address for this interface: 192.195.78.50
    Number of bits in subnet field [0]: 5
    Class C network is 192.195.78.0, 5 subnet bits; mask is 255.255.255.248
Configuring interface Serial0:
  Is this interface in use? [yes]:
  Configure IP on this interface? [yes]:
    IP address for this interface: 192.195.78.34
    Number of bits in subnet field [5]:
    Class C network is 192.195.78.0, 5 subnet bits; mask is 255.255.255.248

The configuration information you provide on this screen is temporary and exists only so that you can proceed with booting your system. When you reload the system, your original configuration is left intact. If your startup configuration is corrupted, enter the setup command facility, and configure the basic parameters. Then issue the copy running-config startup-config or copy system:running-config nvram:startup-config command to write this configuration to NVRAM.

 


Misconceptions:
None

Related Commands:
show version
configure

� Cisco Systems, Inc. 2001, 2002, 2003
World Wide Education

Converted from CHM to HTML with chm2web Pro 2.85 (unicode)