Command:

net


Mode:

Router(config-router)#


Syntax:

net network-entity-title
no net network-entity-title

 

Syntax Description:

network-entity-title NET that specifies the area address and the system ID for a CLNS routing process. This argument can be either an address or a name.

 

Command Description:

To configure an IS-IS network entity title (NET) for a Connectionless Network Service (CLNS) routing process, use the net command in router configuration mode. To remove a NET, use the no form of this command.

By default, no NET is configured and the CLNS process will not start. A NET is mandatory.

Under most circumstances, one and only one NET must be configured.

A NET is a network service access point (NSAP) where the last byte is always zero. On a Cisco router running IS-IS, a NET can be 8 to 20 bytes. The last byte is always the n-selector and must be zero.

The six bytes directly in front of the n-selector are the system ID. The system ID length is a fixed size and cannot be changed. The system ID must be unique throughout each area (Level 1) and throughout the backbone (Level 2).

All bytes in front of the system ID are the area ID.

Even when IS-IS is used to perform IP routing only (no CLNS routing enabled), a NET must still be configured to define the router system ID and area ID.

A maximum of three NETs per router are allowed. In rare circumstances, it is possible to configure two or three NETs. In such a case, the area this router is in will have three area addresses. There will still be only one area, but it will have an additional maximum of three area addresses.

Configuring multiple NETs can be temporarily useful in the case of network reconfiguration where multiple areas are merged, or where one area is split into additional areas. Multiple area addresses enable you to renumber an area individually as needed.

If you are configuring multiarea IS-IS, the area ID must be unique, but the system ID portion of the NET must be the same for all IS-IS routing process instances.


Example:

The following example configures a router with system ID 0000.0c11.1111.00 and area ID 47.0004.004d.0001:

Router(config)# router isis CHESNUT
Router(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00
 

The following example shows three IS-IS routing processes with three areas configured. Each area has a unique identifier, but the system ID is the same for all areas.

Router(config)#interface Tunnel 529
Router(config-if)#ip address 10.0.0.5 255.255.255.0
Router(config-if)#ip router isis BB
Router(config-if)#clns router isis BB
Router(config)#interface Ethernet 1
Router(config-if)#ip address 10.1.1.5 255.255.255.0
Router(config-if)#ip router isis A3253-01
Router(config-if)#clns router isis A3253-01

Router(config)#interface Ethernet 2
Router(config-if)#ip address 10.2.2.5 255.255.255.0
Router(config-if)#ip router isis A3253-02
Router(config-if)#clns router isis A3253-02


Router(config)#router isis BB ! Defaults to "is-type level-1-2"
Router(config-router)#net 49.2222.0000.0000.0005.00 

Router(config)#router isis A3253-01
Router(config-router)#net 49.0553.0001.0000.0000.0005.00
Router(config-router)#is-type level-1

Router(config)#router isis A3253-02
Router(config-router)#net 49.0553.0002.0000.0000.0005.00
Router(config-router)#is-type level-1


Misconceptions:

None


Related Commands:

is-type
router isis

� Cisco Systems, Inc. 2001, 2002, 2003
World Wide Education

Converted from CHM to HTML with chm2web Pro 2.85 (unicode)