Command:

ip router isis


Mode:

Router(config-if)#


Syntax:

ip router isis area-tag
no ip router isis area-tag

 

Syntax Description:

area-tag Meaningful name for a routing process. If it is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or Connectionless Network Service (CLNS) router processes for a given router.

Required for multiarea IS-IS configuration. Optional for conventional IS-IS configuration.

Note Each area in a multiarea configuration should have a nonnull area tag to facilitate identification of the area.

 

Command Description:

To configure an IS-IS routing process for IP on an interface and to attach an area designator to the routing process, use the ip router isis command in interface configuration mode. To disable IS-IS for IP, use the no form of the command.

Before the IS-IS routing process is useful, a network entity title (NET) must be assigned with the net command and some interfaces must have IS-IS enabled.

If you have IS-IS running and at least one International Organization for Standardization Interior Gateway Routing Protocol (ISO-IGRP) process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-IGRP at the same time. However, each area in an IS-IS multiarea configuration should have a nonnull area tag to facilitate identification of the area.

You can configure only one process to perform Level 2 (interarea) routing. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1. You can configure this process to perform intra-area (Level 1) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. Use the is-type command to remove Level 2 routing from a router instance. You can then use the is-type command to enable Level 2 routing on some other IS-IS router instance.

An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media such as WAN media where subinterfaces are supported, different subinterfaces could be configured for different areas.


Example:

The following example specifies IS-IS as an IP routing protocol for a process named Finance, and specifies that the Finance process will be routed on Ethernet interface 0 and serial interface 0:

Router(config)# router isis Finance
Router(config-router)# net 49.0001.aaaa.aaaa.aaaa.00

Router(config)# interface Ethernet 0
Router(config-if)# ip router isis Finance

Router(config)# interface serial 0
Router(config-if)# ip router isis Finance
The following example shows an IS-IS configuration with two Level 1 areas and one Level 1-2 area:

Router(config)# interface Tunnel529
Router(config-if)# ip address 10.0.0.5 255.255.255.0
Router(config-if)# ip router isis  BB

Router(config)# interface Ethernet1
Router(config-if)# ip address 10.1.1.5 255.255.255.0
Router(config-if)# ip router isis  A3253-01

Router(config)# interface Ethernet2
Router(config-if)# ip address 10.2.2.5 255.255.255.0
Router(config-if)# ip router isis  A3253-02

Router(config)# router isis BB
Router(config-router)# net 49.2222.0000.0000.0005.00

Router(config)# router isis A3253-01
Router(config-router)# net 49.0553.0001.0000.0000.0005.00
Router(config-router)# is-type level-1

Router(config)# router isis A3253-02
Router(config-router)# net 49.0553.0002.0000.0000.0005.00
Router(config-router)# is-type level-1


Misconceptions:

None


Related Commands:


is-type
net
router isis

� Cisco Systems, Inc. 2001, 2002, 2003
World Wide Education

Converted from CHM to HTML with chm2web Pro 2.85 (unicode)