Command:  

ip pim


Mode:

Router(config-if)#


Syntax:

ip pim {sparse-mode | sparse-dense-mode | dense-mode [proxy-register {list access-list | route-map map-name}]}
no ip pim

Syntax Description:


sparse-mode

Enables sparse mode of operation.

sparse-dense-mode

The interface is treated in either sparse mode or dense mode of operation, depending on which mode the multicast group operates in.

dense-mode

Enables dense mode of operation.

proxy-register

(Optional) Enables proxy registering on the interface of a designated router (DR) (leading toward the bordering dense mode region) for multicast traffic from sources not connected to the DR.

list access-list

(Optional) Defines the extended access list number or name.

route-map map-name

(Optional) Defines the route map.

Command Description:

To enable Protocol Independent Multicast (PIM) on an interface, use the ip pim command in interface configuration mode. To disable PIM on the interface, use the no form of this command.

Example:

The following example shows how to enable PIM-SM on tunnel interface 0 and set the address of the RP router to 226.0.0.8:

ip pim rp-address 226.0.0.8

interface tunnel 0

ip pim sparse-mode

The following example shows how to enable PIM-DM on Ethernet interface 1:

interface ethernet 1

ip pim dense-mode

The following example shows how to enable PIM sparse-dense mode on Ethernet interface 1:

interface ethernet 1

ip pim sparse-dense-mode

The following example shows how to register the multicast traffic for any source and any multicast group:

interface ethernet 0

ip address 131.108.175.110 255.255.255.0

description Ethernet interface towards the PIM sparse-mode domain

ip pim sparse-dense-mode

!

interface ethernet 1

ip address 192.44.81.5 255.255.255.0

description Ethernet interface towards the PIM dens-mode region

ip pim dense-mode proxy-register list 100

!

access-list 100 permit ip any any


Misconceptions:

None


Related commands:

ip pim rp-address
ip pim send-rp-announce
ip pim send-rp-discovery

 


� Cisco Systems, Inc. 2001, 2002
World Wide Education

Converted from CHM to HTML with chm2web Pro 2.85 (unicode)